little-hesinde/flake.nix
Sebastian Hugentobler 43054212ce
Some checks failed
Build Multiarch Container Image / call-reusable-workflow (push) Failing after 0s
remove musl building with nix for now, clashes with the build script
2024-05-10 22:42:14 +02:00

33 lines
676 B
Nix

{
description = "little-hesinde project";
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
flake-utils.url = "github:numtide/flake-utils";
fenix.url = "github:nix-community/fenix";
};
outputs =
{
nixpkgs,
fenix,
flake-utils,
...
}:
flake-utils.lib.eachDefaultSystem (
system:
let
pkgs = import nixpkgs { inherit system; };
rust = fenix.packages.${system}.stable;
in
{
devShells.default = pkgs.mkShell {
buildInputs = [
rust.toolchain
pkgs.cargo-deny
pkgs.rust-analyzer
];
};
}
);
}