fhnw-tools/PKGBUILD

35 lines
1.1 KiB
Bash

# Maintainer: Sebastian Hugentobler <shu@vanwa.ch>
pkgname=fhnw-tools
pkgver=0.1.0
pkgrel=2
pkgdesc="Various tools to work with the FHNW infrastructure."
arch=("any")
url="https://code.vanwa.ch"
license=('MIT')
depends=("python-ocma" "openconnect" "pass" "sudo" "rsync" "rclone" "vpnc")
source=(
"fhnw-vpn"
"fhnw-ad-mount"
"fhnw-ad-sync"
"fhnw-teams-sync"
"fhnw-sync"
)
sha256sums=(
"fdbdab46cef6ca1413a4e870d4530210ac31edb231336a8a3f2b8f668bcdbce9"
"8e904a89afc434df3ce7538437aec237b7b3c08f5494246e849dc28e710723b7"
"b8cbf2c97bf2c55a91d35bf57c5f9f7a9dd7e63d710d6a5c8a519273a15927f3"
"86e25ae0c820f05e1b3335e593e9dc5f2f77f04f1dbbe534a5e2a8f1c19aa71d"
"983c922d2dc261b6c77e96c0d67c00fa4d24504ad0b0ef1a7fe9d762da9b7b8d"
)
package() {
cd "$srcdir/"
install -Dm 755 fhnw-vpn "$pkgdir/usr/bin/fhnw-vpn"
install -Dm 755 fhnw-ad-mount "$pkgdir/usr/bin/fhnw-ad-mount"
install -Dm 755 fhnw-ad-sync "$pkgdir/usr/bin/fhnw-ad-sync"
install -Dm 755 fhnw-teams-sync "$pkgdir/usr/bin/fhnw-teams-sync"
install -Dm 755 fhnw-sync "$pkgdir/usr/bin/fhnw-sync"
}